vw teilemarkt

Diagnose möglich mit ?

Mav41
  • Themenstarter
Mav41's Lupo

Hallo zusammen,

da ich ja, wie aus meinen anderen Beiträgen bekannt, noch ein BMW E65 habe und dort auch Fehler auslese, möchte ich das am Lupo auch versuchen.Beim BMW geht das sowohl mit Handy als auch mit meinem Laptop , auf dem natürlich noch spezielle Software für BMW ist.

Nun stellt sich die Frage welxhen Adapter ich beim Lupo nehmen kann. Ich wollte das mit einem Bluetooth Adapter und dem Handy machen wie gelegentlich an meinem E65.

Jetzt habe ich schon 2 dieser Bluetooth Adapter gekauft, aber bei keinem bekomme ich eine Verbindung zur ECU.
Bei meinem E65 funktioniert das tadellos.

Könnt Ihr mir ein Adapter empfehlen mit dem das geht? Die Software dafür ist die Torque App fürs Handy.
Die Diagnosebuchse ist im Lupo unter dem Aschenbecher und ist rosa. (OBD I oder OBD II ?)

Gruß Mav



Hallo Mav,

beim Lupo werden in den ersten Modellen fast ausschließlich die K-Leitung, weniger die L-Leitung, in der Fahrzeug-Diagnose benutzt. Da nur wenige Steuergeräte des Lupos mit einer Fehlerdiagnose ausgerüstet waren. Mit der gesetzlichen Einführung von OBDII wurden parallel dazu im Lupo die CAN-high- und die CAN-low-Leitungen geschaltet.

Die Fahrzeug-Diagnose bei einem CAN im Lupo kann weiterhin über die K-Leitung erfolgen wenn ein sogenanntes Gateway benutzt wird.

Eine Fahrzeug-Diagnose über CAN ist aber auch möglich. Auch ist ein Mischbetrieb möglich, d.h. einige Steuergeräte werden über die K-Leitung und andere über die CAN-Leitungen angesprochen.

Dies bedeutet aber auch, dass die "preiswerten" Interfaces nicht alles abdecken können. Die einzelnen PINs der genormten OBDII-Diagnosebuchse sind unterschiedlichen Kommunikations-Protokollen zu geordnet. Auch sind vielfach nicht alle PINs belegt. Man kann sogar von der PIN-Belegung her erkennen, welches Protokoll vom Fahrzeug verwendet wird.

Das ist ein weites Thema. Ich habe mal versucht, dies mit wenigen Sätzen darzustellen.

Fazit: Nicht jedes Interface und Protokoll kann für den Lupo oder auch für andere Fahrzeuge verwendet werden. Universalgeräte sind nicht von Ungefähr im 4 und 5 stelligen EURO-Bereich angesiedelt. Wenn Du ein Interface für den Lupo suchst, achte darauf, dass es die K-Leitung und das KWP1281-Protokoll benutzt. Dann gibt es in der Regel keine Schwierigkeiten.

Die Stromlaufpläne des Lupos, mit Angabe von Baujahr u. Monat, sowie die Motor-Kenn-Buchstaben leisten da ein Hilfe.

Jürgen M.


Jups so unterschiedlich ist es leider.

Bei meinem Würfel mitm alten AKV Block ausm Polo 6N1 (nicht im Lupo)
funktionierts mitm OBD II Stecker per USB Kabel übers Laptop mit der beiliegenden (meistens vervirten) Software VAG-COM um Fehler auszulesen & zu löschen.

Aber per OBD II Bluetooth Adapter übers Handy mit der beliebten Torque (OBD CHECK) App gibt es leider keinen Kontakt zum Steuergerät.



Zitat:

Aber per OBD II Bluetooth Adapter übers Handy mit der beliebten Torque (OBD CHECK) App gibt es leider keinen Kontakt zum Steuergerät.


Das gleiche bei mir mit Lupo GTI und auch am TTRS. Torque (in der Vollversion) funktioniert im TrackRecorder tadellos, Fehlerspeicher und alles darüber hinaus aber nicht.

Das hier brachte abhilfe in sämtlichen Bereichen [Dieser Link ist nur für Mitglieder sichtbar]
4 Wochen Versand bei mir, Geduld zahlt sich aber aus...


Der WBH T5 ist einer, der wohl funktioniert, aber leider nicht mehr lieferbar ist.
[Dieser Link ist nur für Mitglieder sichtbar]

Eine Alternative für den Lupo wäre z.B. die PC-Software CarPort (in 3 Versions-Stufen je nach Anforderungen)
[Dieser Link ist nur für Mitglieder sichtbar]
mit einem USB KKL Diagnose Interface wie z.B. dem AutoDia K409


Hallo Mav,

schau hier mal nach:
[Dieser Link ist nur für Mitglieder sichtbar]

Hier ein Beitrag von mir aus einem anderen Forum:

.....

Natürlich ist für eine erschöpfende Betrachtung die Angabe der Motor-Kenn-Buchstaben, das Baujahr mit Monatsangabe und auch die Angabe ob ein "Nicht-VW-Radio" verbaut ist, einfach erforderlich.
Letzteres kann man einfach prüfen:

Bei allen überwachten Steuergeräte im Lupo sind die K-Leitungen parallel geschaltet. So auch die K-Leitung eines VW-Radios. ( Pin 3 des ISO-Steckers schwarz ). Da der Pin 3 des ISO-Steckers bei " Nicht-VW-Radio " mit Spannung oder ähnl. belegt sein kann .... ist vom Radio abhängig, kann es in dem Falle zu Fehlfunktionen der Diagnose im Lupo kommen, muss aber nicht, ist vom verwendeten Nicht-VW-Radio abhängig. Dieses ist aber auch Thema bei den neueren VW- und Audi-Radios sofern sie der Diagnose des Fahrzeuges zu geordnet sind.

Wir haben sicher alle gelesen, dass der TE schreibt, dass die komplette Einheit, Dateninterface, Leitungen und Protokolle, bei vielen Audi und VW-Fahrzeuge einwandfrei funktioniert hat. Leitungen mit Opto-Kopplern gehören unter der Berücksichtig des Vorgenannten wohl seit längerem der Vergangenheit an. Einen TTL-Baustein dürfte das Interface AutoDia K409 nicht besitzen.

Sonst hätte dies bei den vielen Audi- und VW-Fahrzeugen nicht funktionieren können.

Gemäß den Lupo-Stromlaufplänen Nr.: 1, ab Sept. 1998, hatte der Lupo, Baujahr 1998, noch keinen CAN-Bus für OBD II - Diagnose. Für die Diagnose wurde ausschließlich die K-Leitung benutzt. Das heißt: Die 16-polige Steckverbindung der Diagnose-Steckbuchse im Lupo 1998 hat nur 3 ( drei ) Anschlüsse

Pin 16 / 4 = Masseverbindung

Pin 16 / 7 = Verbindung K-Diagnose-Leitung

Pin 16 / 16 = + 12 Volt über die Sicherung SB 11, 5 A. Ist diese kontrolliert ?

Verbreitete Protokolle für die Diagnose über die K-Leitung sind ISO 9141 und ISO 14230 sowie das von VW herstellerspezifische Protokoll KW1281. Die K-Leitung, auch K-Diagnoseleitung genannt, liegt an Pin 16/7, Pin 7 des 16 poligen Diagnosesteckers, dort wo Du das Diagnose-Interface anschließt. Nun wäre zu klären ob Dein Diagnose-Gerät diese Leitung auch in der notwendigen Form benutzt.

Die Bezeichnung K-Leitung kennzeichnet eine Diagnose Daten Leitung TXD. Dies bedeutet das der PIN 7 des Diagnose-Steckers, einem genormten Protokoll zu geordnet ist. Dies sind die Protokolle ISO 9141 und ISO 14230 für die K-Leitung.

Auch herstellerspezifische Protokolle werden über die K- und L-Leitungen eingesetzt. Hier ist das Protokoll KW1281 ( VAG ), nur für die K-Leitung zu erwähnen. Zu der K-Leitung gibt es noch eine L-Leitung, die aber nicht weiter durch die billigen Interfaces benutzt wird. ( K=slow, L=fast ). Meines Wissen wird die L-Leitung bei VAG nicht benutzt.

Nun kommt aber das wichtigste: Im Internet werden billige Diagnose-Interfaces, mit Anzeigen wie ISO 9141, ISO 14230 oder OBD II angeboten, welche dem Käufer Sand in die Augen streuen und weis machen wollen, dass das Interface diese Protokolle beherrscht. Nichts von alle dem. Bei diesen Interfaces handelt es sich stets nur um Signalumsetzer, die in der Regel keine eigene Protokoll-Logik beinhalten, Diagnose-Adapter, welche diese Funktionsweise ( K-Leitung ) unterstützen werden als KL-Interfaces bezeichnet.

Für ältere Fahrzeuge, wie der Lupo von 1998, die noch nicht über OBD II verfügen, sind diese so genannten KL-Adapter oder KL-Interfaces zusammen mit dem zum Fahrzeug-Protokoll passenden Software-Protokoll KW1281 für die Diagnose notwendig. Suche da mal den Fehler.

Wenn Du weder Interface, noch PC, noch das Programm ( Keine Kopie, wo der Aktivierungscodes erneut eingegeben werden müssen ) verändert hast, müsste nach wenigen Sekunden das Interface und das KW 1281-Protokoll vom Programm erkannt werden.

Poste mal bitte die Motor-Kenn-Buchstaben und Baujahr mit Monat damit kontrolliert werden kann welcher Diagnose-Anschluss bei Deinem Lupo vorliegt. Alles andere ist vorerst Raterei.

Hast Du Unterlagen über das AutoDia K409 ? Bei allen Ausleseversuchen der Speicher war doch die Zündung eingeschaltet ? Sonst bekommt das Interface keine Versorgungsspannung.

Nachtrag: Das Interface hat auf der einen Seite den genormten 16-poligen Diagnose-Anschluss und auf der anderen Seite in der Regel einen USB-Stecker. Warum denn dieses ? Weil schon seit Jahren PCs und Laptops über keine serielle COM - Schnittstellen, welche nach außen geführt sind, mehr verfügen. Aus diesem Grunde werden von den Programmen serielle Schnittstellen emuliert.

Es können aber nur COM-Schnittstellen emuliert werden, welche im PC-System vorhanden sind. Das liegt in den Programmen begründet.

Es gibt auch noch die Möglichkeit, dass bei einigen Interface der COM-Port im Programm manuell eingestellt werden muss.


Habe eine Aufstellung gefunden, dass der Diagnose-Adapter AutoDia K409 :

1.) Nur mit der K-Leitung eines CAN-Bus OBDII funktioniert.

2.) Er funktioniert nicht mit der VAG- K-Leitung ....... die des Lupos

3.) Er funktioniert auch nicht mit dem VAG-CAN-Bus



Warum, war dem Beitrag nicht zu entnehmen. Die Interfaces AGV 4000 Expert, AGV 4500 und Diamex DXM-1 Expert sowie Scandevil 2 funktionieren mit allen drei

Jürgen M.




Da der TE (Mav41) laut seinem Profil einen Lupo 1.0 Bauj. 2000 besitzt, ist davon auszugehen, dass dieser bereits mit CAN-Bus ausgestattet ist, denn es gilt damit auch der Lupo-Stromlaufplan Nr. 48 - gültig ab Mai 1999. Darin sind auch Pin 6 u. 14 für can-h und can-l beschaltet. Trotzdem wird aber weiterhin das Protokoll KW1281 über K-Line genutzt.
Im übrigen kann ich mir auch nicht vorstellen, warum die Firma CarPort in ihren Anzeigen hinsichtlich der Verwendbarkeit des K409 und K509 in der Version mit KKL falsche Angaben machen sollte.
Ich selbst habe beim FSI 2001 einen -ich unterstelle mal mit dem K409 baugleichen- Adapter mit der Aufschrift "VAGKKL" von der Fa. MyOBD bereits mit der CarPort Free-Edition erfolgreich testen können.
Muss allerdings dazu sagen, dass selbst das Pro-Modul von CarPort wohl nicht mit dem von mir inzwischen genutzten VCDS Pro vergleichbar ist.


Zitat:

Habe eine Aufstellung gefunden, dass der Diagnose-Adapter AutoDia K409 : 1.) Nur mit der K-Leitung eines CAN-Bus OBDII funktioniert.2.) Er funktioniert nicht mit der VAG- K-Leitung ....... die des Lupos3.) Er funktioniert auch nicht mit dem VAG-CAN-Bus Warum, war dem Beitrag nicht zu entnehmen. Die Interfaces AGV 4000 Expert, AGV 4500 und Diamex DXM-1 Expert sowie Scandevil 2 funktionieren mit allen drei


Den Link zum obigen Text habe ich leider wieder gelöscht. Damals ging es um einen 1998 er Lupo. Ich erinnere mich, dass kein von / bis Datum angegeben war. Vielleicht finde ich den Link wieder.

Hier mal ein Link der die verschiedenen Diagnose-Adapter betrachtet .... was mit wem so funktioniert.
[Dieser Link ist nur für Mitglieder sichtbar]?

Jürgen M.


Mav41
  • Themenstarter
Mav41's Lupo

Hallo zusammen,

wollte mich noch für eure Hilfe bedanken und Bescheid sagen das es nun mit dem Teil welches SBS mit empfohlen hat endlich geklappt hat.

Eine Verbindung bekam ich hin mit dem Kabel und der Software die dabei war.
Jetzt muss ich mich lediglich noch etwas vertrauter mit der Soft machen, da diese doch etwas ganz anderes als bei meinem BMW das Ediabas/Inpa ist.

Gibt es dazu irgendwelche Literatur die ich mal lesen kann?
Oder kann SBS mir da etwas unter die Arme greifen?



viel mehr kann ich inhaltlich nicht helfen, nutze es nut sehr sporadisch und am Lupo inzwischen nicht mehr. Bei mir auf der CD ein Handbuch auf deutsch dabei, das fand ich recht ausführlich.

Ansonsten am besten konkrete Fragen im Forum hier stellen, da gibt es sicher den ein oder anderen VCDS Spezialisten.


Mav41
  • Themenstarter
Mav41's Lupo

Hi SBS,
dann werde ich mir die Anleitung nochmal zu Gemüte führen.

Wenn man aber hier über die Soft fragen stellen darf ist das auch ok. Dachte dass wäre verboten


Verboten ist es natürlich jegliche SW illegal zu erwerben. Gegen die Nutzung eines Shareware spricht natürlich nichts...

Oder gegen die Fragen "Wie kann ich mit VCDS xyz machen"


Mav41
  • Themenstarter
Mav41's Lupo

Alles klar - dann kann ich ja mal die eine oder andere Frage stellen


Mav41
  • Themenstarter
Mav41's Lupo

Hallo zusammen,

da sich die Tochter letzte Woche nun vom Lupo getrennt hat, benötige ich das Diagnose Kabel incl. Soft nicht mehr.
Hat jemand interesse an dem Kabel mit der Software dabei?

Bei interesse einfach melden. Habe es 1x benutzt!

Gruß Jürgen


Antworten erstellen